Wins Security Information

취약점 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2021-42013] Apache Directory Traversal
작성일 2021-12-03 조회 67

 

 

 

 

Apache에 Directory Traversal 취약점이 존재합니다.

 

해당 취약점은 CVE-2021-41773의 불충분한 패치로 인해 발생하며, 요청 URI 경로의 부적절한 유효성 검사로 인해 발생합니다. 원격의 공격자는 악의적으로 조작된 요청을 전송하여 공격할 수 있습니다.

 

공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 설명

 

NVD - CVE-2021-42013

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH

 

 

[그림1. NVD 내역]

 

 

 

취약점 분석

 

 

해당 취약점은 ap_normalize_path() 함수에서 URI 경로에 대한 부적절한 유효성 검사로 인해 발생합니다.

 

 

 

[그림2. /server/request.c 코드 일부]

 

 

HTTP 요청은 ap_process_request_internal() 함수를 통해 처리되는데 해당 함수는 ap_normalize_path() 함수를 사용하여 경로를 정규화합니다.

 

 

 

[그림3. /server/util.c 코드 일부]

 

해당 함수를 통해 '////','../' 문자열과 url 인코딩된 값을 탐지하여 해당 문자열이 포함된 경로로 접근할 경우 이를 차단합니다.

 

하지만 해당 함수에서는 두번 url 인코딩된 경우에 대해서는 검사하지 않기 때문에 예를 들어 '.' 이 두번 url 인코딩 된 값인 '%%32e'를 통해 이를 우회할 수 있습니다.

 

이로 인해 임의의 공격자 또는 사용자는 URI에 다양한 우회구문을 사용하여 임의의 폴더에 접근하거나 코드를 실행할 수 있게 됩니다.

 

 

취약한 버전은 2.4.49, 2.4.50 버전으로 2.4.51 버전에서 패치되었습니다.

 

 

 

공격 분석

 

 

CVE-2021-42013의 공격 패킷은 다음과 같습니다.

 

 

 

[그림 4. 공격 패킷]

 

 

공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 대응 방안

 

1. 최신 버전 사용

 

해당 벤더사가 발표한 보안 권고문을 참고하여 최신의 버전으로 업데이트한다.

https://httpd.apache.org/security/vulnerabilities_24.html

 

 

2. WINS Sniper 제품군 대응 방안

 

[5695] Apache httpd ap_normalize_path Directory Traversal.B 외 22개

 

첨부파일 첨부파일이 없습니다.
태그 CVE-2021-42013  Apache  DirectoryTraversal