Wins Security Information

보안 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2017-16921] OTRS RCE
작성일 2021-06-07 조회 217

 

 

 

OTRS는 Open-source Ticket Request System의 약자로 자유 및 오픈 소스 티켓 시스템 소프트웨어 패키지로서 기업, 단체가 수신 쿼리에 티켓을 할당하고 이들에 대한 추가 통신을 추적하는데 사용합니다.

 

해당 취약점은 /index.pl? 경로에서 Action 파라미터의 값이 AdminSysConfig이고 SysConfigGroup 파라미터의 값이 Framework일 때 PGP::Bin 파라미터의 값을 충분히 검증하지 않아 발생합니다. 원격의 공격자는 악의적으로 조작된 HTTP 요청을전송하여 공격할 수 있습니다.

 

 

공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 설명

 

NVD - CVE-2017-16921

CVSS v2.0 Severity and Metrics:

Base Score: 9.0 HIGH

 

 

 

[그림1. NVD 내역]

 

 

 

취약점 분석

 

해당 취약점은 사용자가 3개의 파라미터 값을 임의로 조작할 수 있어 발생됩니다.

 

3개의 파라미터는 PGP, PGP::Bin, PGP::Options로 각 파라미터의 디폴트값은 다음과 같다.

 

"PGP": No

"PGP::Bin": /usr/bin/gpg

"PGP::Options": --homedir /opt/otrs/.gnupg/ --catch --no-tty --yes

 

해당 파라미터 값에 경로나 공격 구문을 직접 삽입/입력함으로써 임의의 코드가 실행될 수 있습니다.

 

 

 

공격 분석 및 테스트

 

CVE-2017-16921의 공격 패킷은 다음과 같습니다.

 

 

 

[그림2. 취약한 패킷]

 

 

취약점 대응 방안

 

1. 최신 버전 사용

 

해당 벤더사에서 발표한 최신의 버전으로 업데이트한다.

https://community.otrs.com/security-advisory-2017-09-security-update-for-otrs-framework-2/

 

 

2. WINS Sniper 제품군 대응 방안

 

[5462OTRS index.pl PGP Bin RCE

[5463OTRS index.pl PGP Options RCE

 

첨부파일 첨부파일이 없습니다.
태그 CVE-2017-16921  OTRS  RCE